System compatibility

Requirements

  • PHP version must be at least 5.3.3 (5.6.25 installed)
  • PHP version must not be 5.3.16 as Symfony won't work properly with it
  • Vendor libraries must be installed
  • cache/ directory must be writable
  • log/ directory must be writable
  • conf/ directory must be writable
  • library/Proxy/ directory must be writable
  • themes/ directory must be writable
  • plugins/ directory must be writable
  • public/ directory must be writable
  • images/ directory must be writable
  • date.timezone setting must be set
  • Configured default timezone "UTC" must be supported by your installation of PHP
  • json_encode() must be available
  • session_start() must be available
  • ctype_alpha() must be available
  • token_get_all() must be available
  • simplexml_import_dom() must be available
  • detect_unicode must be disabled in php.ini
  • PCRE extension must be available

Recommendations

  • sendmail should be installed
  • You should use at least PHP 5.3.4 due to PHP bug #52083 in earlier versions
  • When using annotations you should have at least PHP 5.3.8 due to PHP bug #55156
  • You should not use PHP 5.4.0 due to the PHP bug #61453
  • You should use PHP 5.3.18+ or PHP 5.4.8+ to always get nice error messages for fatal errors in the development environment due to PHP bug #61767/#60909
  • PCRE extension should be at least version 8.0 (8.37 installed)
  • PHP-XML module should be installed
  • mb_strlen() should be available
  • iconv() should be available
  • utf8_decode() should be available
  • posix_isatty() should be available
  • intl extension should be available
  • intl extension should be correctly configured
  • intl ICU version should be at least 4+
  • a PHP accelerator should be installed
  • short_open_tag should be disabled in php.ini
  • magic_quotes_gpc should be disabled in php.ini
  • register_globals should be disabled in php.ini
  • session.auto_start should be disabled in php.ini
  • PDO should be installed
  • PDO should have some drivers installed (currently available: mysql, sqlite)
All is well! There are some warnings but you can continue installation. Next Refresh

Newscoop, the open content management system for professional journalists.
© 2016 Sourcefabric z.รบ. Newscoop is distributed under GNU GPL v.3